# 基础库常见问题

如出现以下报错,可根据本FAQ,进行问题自查

# 1. 问题表现

问题表现1:代码报错

result:0---error:Error Domain=FATDomain Code=0 "基础库下载失败" UserInfo={NSLocalizedDescription=基础库下载失败}

问题表现2:打开小程序报错
图片.png

# 2. 问题排查

# 2.1 使用符合基础库版本的SDK版本

运行时-基础库版本对照表 页面查看SDK版本与基础库版本的对应关系,当使用了超出基础库版本的SDK时,将出现以上报错信息。

解决方法为升级/降级至对应版本的运行时SDK。

  • 情况一
    如基础库版本为1.3.8,对应的iOS版SDK版本为2.1.23,低于2.1.23获取不到1.3.8,同样Android SDK对应版本为2.1.38,低于2.1.38获取不到1.3.8的基础库;
  • 情况二
    如SDK版本2.1.23同时满足1.3.8、1.3.9、1.4.0三个版本的基础库,那么该SDK获取到的基础库将是最高版本的1.4.0;

# 2.2 发布符合当前SDK版本的基础库

请注意

对于私有化或社区版客户,可通过在运营端上传符合当前版本的基础库解决报错问题,您可寻找对应的销售经理或客服人员获取最新的基础库文件。

基础库上传位置为:运营端 -> 小程序管理 -> 小程序基础库

基础库包版本可在 基础库更新日志 中查看
image.png

© 2021 凡泰极客
  • 免费试用
  • 编组
  • 编组 2